Ajuda com código de Exercício de Lógica de Programação

0 Votos
Estou no curso de Lógica de Programação no Modulo 3 no exercicio complementar do modulo nele pede o seguinte:
“Crie um algoritmo que solicite o número da poltrona. Se a posição estiver vazia então ela passará a ser ocupada. O algoritmo termina quando o usuário digita o valor 0 (zero). Considere que exista 2 fileiras com 5 poltronas e no início todas estejam vazias.”
Eu criei tudo certinho, mas meu código saiu um pouco grande, eu fiz com o que veio vindo em minha cabeça, queria saber se teria com simplificar o código, segue o código abaixo:
————————————————– Código ————————————————–
algoritmo “Aninhamento de Para…Faça”
var
    Matriz: vetor[1..2,1..5] de Caractere
    L,C:inteiro
    x:Inteiro
inicio
para L de 1 ate 2 faca
     para C de 1 ate 5 faca
     Matriz[L,C] <- “v”
     fimpara
fimpara
x <- 1
Enquanto x >= 1 faca
         Enquanto x <= 10 faca
         
Escreval (“Digite o número de poltrona de 1 a 10: “)
Leia (x)
se x = 0 entao
interrompa
fimse
se x = 1 entao
   se Matriz[1,1] = “p” entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   
   se Matriz[1,1] = “v” entao
   Escreval (“Poltrona Vazia”)
    Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
    Escreval (“”)
   Matriz[1,1] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 2 entao
   se Matriz[1,2] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[1,2] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[1,2] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 3 entao
   se Matriz[1,3] = “p” entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[1,3] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[1,3] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 4 entao
   se Matriz[1,4] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[1,4] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[1,4] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 5 entao
   se Matriz[1,5] = “p” entao
   Escreval(“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[1,5] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[1,5] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 6 entao
   se Matriz[2,1] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[2,1] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[2,1] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 7 entao
   se Matriz[2,2] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[2,2] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[2,2] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 8 entao
   se Matriz[2,3] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[2,3] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[2,3] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 9 entao
   se Matriz[2,4] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[2,4] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[2,4] <- “p”
   fimse
fimse
//——————————————————————–//
se x = 10 entao
   se Matriz[2,5] = “p”  entao
   Escreval (“A poltrona está ocupada”)
   Escreval (“”)
   fimse
   se Matriz[2,5] = “v” entao
   Escreval (“Poltrona Vazia”)
   Escreval (“”)
   Escreval (“A poltrona foi preenchida”)
   Escreval (“”)
   Matriz[2,5] <- “p”
   fimse
fimse
   Fimenquanto
Fimenquanto
fimalgoritmo

0

Respostas


Cadastre-se ou faça login para responder a esta pergunta.